Commit 982d7ffd authored by Chris Holbrook's avatar Chris Holbrook

add version = 2 to prevent changing dependency to R 5.3 due to message...

add version = 2 to prevent changing dependency to R 5.3 due to message 'because serialized objects in serialize/load version 3'
parent 9428c309
No preview for this file type
......@@ -6,7 +6,7 @@ add_internal_data <- function(x, rda_file) {
e <- new.env()
load(rda_file, e) #load existing internals to new envir
assign(deparse(substitute(x)), x, envir = e) #add/replace with new object
save(list = ls(e), file = rda_file, envir = e)
save(list = ls(e), file = rda_file, envir = e, version = 2)
}
#--------------------------------------------------------------------------
......@@ -15,5 +15,5 @@ remove_internal_data <- function(x, rda_file) {
e <- new.env()
load(rda_file, e) #load existing internals to new envir
rm(list = deparse(substitute(x)), envir = e) #remove unwanted object
save(list = ls(e), file = rda_file, envir = e)
save(list = ls(e), file = rda_file, envir = e, version = 2)
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment